linux系统中apktool和aapt工具的安装和简单使用方法

下载安装apktool和aapt工具

apktool和aapt各种版本可以到如下地址下载,以下以apktool 2.2.2为例

http://connortumbleson.com/apktool/

下载 wrapper script

# wget https://raw.githubusercontent.com/iBotPeaches/Apktool/master/scripts/linux/apktool

下载apktool,重命名为apktool.jar

# wget http://connortumbleson.com/apktool/apktool_2.2.2.jar
# mv apktool_2.2.2.jar apktool.jar

下载 aapt

http://connortumbleson.com/apktool/aapt/linux/aapt

新建/usr/local/apktool文件夹,将 apktool,apktool.jar和aapt移进来

# mv apktool apktool.jar aapt /usr/local/apktool

赋予 apktool,apktool.jar和aapt可执行权限

# chmod +x apktool apktool.jar aapt

将apktool加入环境变量,修改/etc/profile,添加如下内容

export PATH="$PATH:/usr/local/apktool"

使环境变量立即生效

# source /etc/profile

使用aapt工具时可能报如下错误

aapt: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by aapt)

解决使用aapt命令时出现 GLIBC_2.14’ not found 问题

缺少glibc-2.14,安装一下就好了

# wget http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz
# tar zxvf glibc-2.14.tar.gz
# cd glibc-2.14 
# mkdir build
# cd build
# ../configure --prefix=/opt/glibc-2.14
# make -j4
# make install

方法一

修改/etc/profile,添加如下一行

export LD_LIBRARY_PATH=/opt/glibc-2.14/lib:$LD_LIBRARY_PATH

使环境变量生效

# source /etc/profile

方法二

方法一可能导致其他程序不可用,更安全一点的方法如下:
切换到/usr/local/apktool

cd /usr/local/apktool

首先将aapt重命名为aapt_

mv aapt aapt_

再新建一个脚本aapt使用glibc 2.14环境变量

vim aapt

写入以下内容

#!/bin/sh
echo "$0"_$@
export LD_LIBRARY_PATH=/opt/glibc-2.14/lib && "$0"_ $@

然后给aapt相应的权限

chmod 755 aapt

apktool和aapt简单使用方法

# apktool d /data/test.apk //反编译apk
# aapt dump badging /data/test.apk //查看apk包详细信息
36nu 分享编程知识及经验

已有账号?立即登录